Problema com a Unity estaria atrasando o lançamento de jogos para o Switch

yooka-laylee

Ontem o pessoal da Playtonic soltou um comunicado que desagradou todos aqueles que esperam o lançamento do Yooka-Laylee para o Nintendo Switch. Nele o estúdio informava que o motivo para o jogo ainda não ter sido lançado para o console era a espera pela chegada da nova versão da engine Unity (5.6). Porém, junto com essa atualização a desenvolvedora descobriu que ela causava diversos problemas de performance no título e por isso eles precisariam de mais tempo de desenvolvimento.

O grande problema é que a dificuldade que a Playtonic está enfrentando com o desenvolvimento não é um caso isolado, já que pelo menos mais um estúdio estaria passando pela mesmo situação. Conforme revelou na sua página no Kickstarter, a Airship Syndicate também teve que adiar indefinidamente o lançamento do Battle Chasers: Nightwar para o Switch e o motivo novamente seria a Unity.

No momento, a versão para o Switch está atrasada e não temos certeza até quando. Estamos esperando algumas atualizações para a Unity que precisamos antes de podermos prometer confortavelmente uma data de lançamento para o jogo. Sabemos que esta é uma versão muito aguardada do Nightwar, então não encaramos esse adiamento levemente, mas a nossa prioridade número um é garantir que a versão que lançarmos atinja os padrões esperados.

No caso do Battle Chasers: Nightwar, o estúdio informa ainda que aqueles que contribuíram com a campanha de financiamento coletivo e que não quiserem esperar por esta versão poderão pedir uma cópia para outra plataforma, mas assim que tiverem alguma novidade sobre o lançamento para o Switch, informarão imediatamente.

Tudo leva a crer portanto que a tão aguarada atualização 5.6 para a Unity tem dificultado bastante o trabalho de algumas desenvolvedoras. Isso é curioso, porque se por um lado com ela os estúdios ganharam gráficos melhores, suporte a API Vulkan e efeitos de iluminação mais realista, por outro parece ter se tornado mais difícil fazer com que os jogos criados com a engine rodem satisfatoriamente no aparelho da Nintendo.

Rodando em praticamente todas as plataformas, a Unity se tornou uma das engines favoritas das desenvolvedoras, mas algo como o relatado pela Playtonic e pela Airship Syndicate poderá ter uma impacto bastante negativo no futuro da ferramenta. Até o momento os responsáveis pelo kit de desenvolvimento não se pronunciaram sobre tais casos, mas como esta atualização foi lançada há seis meses, pode ser que uma nova versão já esteja a caminho.

Fonte: Game Informer.

Relacionados: , , , , ,

Autor: Dori Prata

Pai em tempo integral do pequeno Nicolas, enquanto se divide escrevendo para o Meio Bit Games, Techtudo e Vida de Gamer, tenta encontrar um tempinho para aproveitar algumas das suas paixões, os filmes, os quadrinhos, o futebol e os videogames. Acredita que um dia conseguirá jogar todos os games da sua coleção.

Compartilhar
  • Fernando Silva

    Mas que filho de maracutaia atualiza o programa pouco antes do lamentoso do produto. Tem que tomar na cabeça mesmo…

    • Se for crucial pro funcionamento de algo não tem muito o que fazer.

    • Daniel Tiecher

      No caso do Yooka-Laylee eles tiveram que atualizar a versão pois a 5.6 corrigiu alguns bugs que estavam impactando a performance do jogo no Switch. O que eles não esperavam era dar merda em outros lugares…

      • Nilton Pedrett Neto

        QQ um que usa Unity sabe que não rola começar o projeto numa versão e terminar na outra. Se tem problemas, corrige na unha. Certamente o problema é outro e tão botando a culpa na engine.

  • Guilherme

    Que eu saiba já tem versão mais nova do Unity – o Unity 2017. Talvez não tenha adereçado estes problemas. Ou talvez eles estivessem esperando uma atualização menor sobre o 5.6, já que pular para o 2017 poderia dar muitos problemas de compatibilidade.

    • Atualizar pra próxima versão e não para atualização da versão corrente é pedir pra tudo parar de funcionar hahaha

  • Manuel Pedro Pereira

    Unity sempre foi uma merda, estranho seria se ela nao estivesse dando dor de cabeça

    • SomeReader

      Eu gosto do Unity. Desenvolvi vários mini jogos por eles.

    • Nilton Pedrett Neto

      Pq vc não gosta da unity?

  • Germano

    Pergunta do leigo aqui: por que não ficaram na versão antiga?

    • SomeReader

      Pelo que entendi, com a versão nova:
      “os estúdios ganharam gráficos melhores, suporte a API Vulkan e efeitos de iluminação mais realista”

      • Dou uma e se for bom dou mais

        Só que se eles estavam com o jogo praticamente pronto, então para adicionar esses novos recursos eles precisariam de qualquer forma adiar o lançamento… Então novamente como foi dito “Se não está quebrado, não conserte”

        • SomeReader

          É, eu sei…. eu concordo. Eu tb não iria esperar, provavelmente. Mas vai da cabeça dos desenvolvedores né…

    • SomeReader

      Não que isto responda totalmente sua pergunta… mas…. ok.

    • Gesonel o Mestre dos Disfarces

      “Se não está quebrado, não conserte”. rs!

    • Fernando Marquardt

      O suporte ao Switch só veio na versão 5.6.

      • Dou uma e se for bom dou mais

        A bom… ai sim a gente entende.

  • VULKAN é a API que permite jogos com bons gráficos no Switch. Já tivemos Doom… vamos ver o que mais vai aparecer nos próximos anos.

    Tinha fé na Unreal Engine, mas ainda não vi nada.

Aproveite nossos cupons de desconto:

Cupom de desconto Locaweb, Cupom de desconto HP, Cupom de desconto Descomplica, Cupom de desconto Nuuvem, Cupom de desconto CVC, Cupom de desconto Asus, Cupom de desconto World Tennis